Bug no Netbeans 6.5.x com RSpec >= 1.1.12

Quem trabalha com Netbeans 6.5.x para desenvolvimento Rails utilizando o RSpec deve ter percebido que com a atualização para a versão mais nova do framework seus testes simplesmente não rodam mais a partir da IDE.

Algo como isso aparece no seu ‘output’:

from E:/cms/cms3/vendor/plugins/rspec/lib/spec/runner/options.rb:101:in `run_examples'
Finished in  seconds

0 examples, 0 failures
	from E:/cms/cms3/vendor/plugins/rspec/lib/spec/runner/command_line.rb:9:in `run'
	from E:/cms/cms3/script/spec:5

Para resolver é simples. Substitua o arquivo $NB_PATH/ruby2/nb_rspec_mediator.rb por esse aqui.

Você também pode baixar a versão 6.7 de desenvolvimento, mas, particularmente, não recomendo. Ela ainda não está estável e ocorrem muitos bugs.

Abraços e bons códigos.

0 Responses to “Bug no Netbeans 6.5.x com RSpec >= 1.1.12”



  1. Deixe um Comentário

Deixe uma Resposta

Preencha os seus detalhes abaixo ou clique num ícone para iniciar sessão:

Logótipo da WordPress.com

Está a comentar usando a sua conta WordPress.com Terminar Sessão / Alterar )

Imagem do Twitter

Está a comentar usando a sua conta Twitter Terminar Sessão / Alterar )

Facebook photo

Está a comentar usando a sua conta Facebook Terminar Sessão / Alterar )

Google+ photo

Está a comentar usando a sua conta Google+ Terminar Sessão / Alterar )

Connecting to %s




Categorias

Por data

Abril 2009
M T W T F S S
« Mar   Abr »
 12345
6789101112
13141516171819
20212223242526
27282930  

Arquivo



%d bloggers like this: